Jump to content
Printer Reset Forum
boxx17

XP-15000 Chipless Installation "The printers firmware was not updated"

Recommended Posts

Hi, 

I am having some trouble finding the instructions for installing the chipless firmware for Epson XP-15000, so I am guessing at the process from just a few comments I have read.

I was able to run the firmware installer (XP15000_FWG150TL_NW20I7_NW99Z9) and upload it to the printer in program update mode (via USB), that seems to work ok. It says "finished". The buttons don't work so I can only unplug it to turn it off. How do I know if it worked? When I go into settings on the printer and view the firmware version, I just see NW2017. It still barks at me about ink levels (I suppose it would until I purchased the license).

When I run the firmware installer in normal mode, the screen indicates its updating firmware for a minute or two and then, just goes to the normal epson menu (maintenance, settings, wifi) but the power light flashes steadily (but maybe because one ink cart is out?) The app on the PC will continue to slowly progress all the way to 100% where then I finally get the message "The printer's firmware was not updated." 

Did it update the first time around and I am just not aware? I didn't want to buy the license until I had some sort of confirmation its installed and will work correctly. Without instructions, I am not clear if I already updated it in 'program update mode' following the small instruction set where you download the firmware prior to buying the license or if thats just testing - or if I am supposed to do that in normal mode? - Some other models look like I am supposed to do it in normal mode, but thats the bit thats not working. 

Any help would be appreciated. Thank you!

Annotation 2020-02-22 023036.png

Annotation 2020-02-22 024136.png

Share this post


Link to post
Share on other sites

NW20I7 is correct version so most likely it is already updated, to make sure run license.exe and click Activate Online button, if you see some data readed in the top input field then firmware is succesfully loaded.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...