Jump to content
Printer Reset Forum

Epson SC-P600 firmware not updating

Recommended Posts

I am at the first stage of installing the firmware via EPFWUPD.exe. I have followed the instructions to the letter, but the update continuously fails. I have tried at least 10 times (probably more).

During the initial installation starts well, the printer reboots at 71% (ish) although it pretty much jobs straight up to 71%. After the reboot it reaches 85% and sloooowly works itself up to 99% before failing installation.

I have checked all the Epson processes have been closed, I also used WICReset to make sure, I am installing it in normal mode, it's connected via USB and detected. I also tried installing it as admin. I have rebooted PC and printer several times.

The thing is, this is the second key I have bought. First time it worked flawlessly , but I installed it via the WICReset (old method), however this does not work this time, the key don't exist... Point is, I know it works on this specific printer.

What just don't know what to do next or if there is anything else I can try.




Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...