Jump to content
WIC Reset Program and Chipless Firmware
Wayne McCracken

XP-15000 - I ran the updater for fwg150tl

Recommended Posts

Epson 15000.

At the middle of the updating, the utility said something like "firmware update confirmed" but at the end it said error, update did not complete and that I should retry. I did that with the same result.

If it is actually updated per the message should I buy and try a chipless key? I don't want to do that if it can't work and I will have wasted my money.

Printer screen now says "Cannot recognize ink cartridge". That was the problem at the beginning after the printer was updated by Epson.


Share this post

Link to post
Share on other sites

When Firmware Update process is complete - printer will restart - usually it will take only a few minutes but can continue for 10-20 minutes in some rare cases. 
If process hangs - replug power cable and start printer manually.

Now check current firmware version ( how to check ). 
If firmware version is NW07K7  - firmware has been uploaded successfully. You can go to next Step. 
If NO - restart the printer and try once more time.

Just follow step by step guide - https://www.2manuals.com/product_info.php?cPath=107&products_id=1857

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...