Jump to content
WIC Reset Program and Chipless Firmware
Sign in to follow this  

Eason wf2850 no recovery code

Recommended Posts

Hi I have been updating the Epson WF2850s for a while now with no issues, did a printer yesterday and all,was ok. Today I tried to activate the key for 2 different printers and the progress bar goes all the way across,but no confirmation or even an error will show, it then doesn’t give me a recovery code. I reinstalled the license.exe file (I noticed a new download versions so tried both) and for the keys I purchased today all of these are doing the same thing (I’m hoping I didn’t ruin the 5 keys I purchased by trying them), just no confirmation or recovery code. I then tried to use a key I know I have redeemed and I get the error telling me that it can’t be activated as I would have expected.Any ideas? I have done these all the same way, never had any issues. I have also restarted the computer, unplugged the printers, re did the firmware in case it hadn’t loaded, swapped USB port and cord, checked the computer internet protections wasn’t conflicting as well. I have another 5 printers I need to add the keys to in the next day or so so now I’m stressing. 
thank you :)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...