Jump to content
WIC Reset Program and Chipless Firmware

Epson wf-7830 initial flag off

Recommended Posts

Hello readers and forum techs, i have an epson wf-7830 printer that has given 2 weeks of headache now. I will try my best to describe the genesis of everything.

Initially the printer was installed with ciss and worked perfect. But during transportation, ink spill in the printer head contacts with fcc cable. Few visible burns were present. But i trimmed the fcc and cleaned the printer head contacts. Ofcourse the fuse in the board was broken and i replaced it with another fuse. However by the time the printer was brought fo me, the fuse had been looped. I removed the loop and put a good fuse.

Now when i connected back everything, the printer goes on in several different ways. 

First, it opens in printer inspection mode, there is a list of the inspections. After i tried all of them, an error 031006 appears. Indicating that fuse is broken but in actual sense the fuse is not broken. The below image 001 shows how the printer screen appears .

Secondly, the printer may as well come on with a screen for fax test mode as in image 1 then after a short while the screen turns to as shown in image 2. With a warning to press on button then a red screen appears saying flag check. Initial flag off and inspection flag on as shown in figure 3.

My 2 geatest concerns here are the error code 031006 which signifies fuse is open and is not. I removed same head and installed in epson wf 3820, which appears to be the A4 version of wf-7830, and finished all initial checks to home screen and ready to print. So apart from fuse, ffc cables and head, or main board, what else could cause error 031006? Point to note is that when i turn on the printer in service mode, and select special inspection, the error that comes is 031004, but normal mode or normal inspection brings the 031006 error.

Secondly, could lal this trouble be caused by failure of the printer not being initialized, then how do you initialize, i have failed all attempts to get its firmware online. And the firmware displayed by wic tool is CB03L8.

Please members assist me how i can have this printer working again.

Thanks in advance.


image 001.jpg

image 1.jpg

image 2.jpg

image 3.jpg

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...