Jump to content
WIC Reset Program and Chipless Firmware

PX710w, is chipless firmware available?

Recommended Posts

Hi. Does anyone know if there is chipless firmware available for the Epson px710w?

I have cartridges not recognised for all inks, have tried everything to resolve it, I presume the firmware has been updated. It wont even accept genuine Epson cartridges. I'm guessing chipless firmware would fix the issue, hopefully.

Cheers. Jimdoe9000

Share this post

Link to post
Share on other sites

It could be a hardware problem yes, but I tried putting them in one by one and they disappear as if they are being recognised, so the system is at least recognising that cartridges are being put in, but then at the end after loading them all in and closing the lid for the final time they then all appear as not recognised again. 

I've read that sometimes the Epson firmware updates can even damage the printer to the point they don't even recognise Epson original cartridges, which is why I suspect it still could be the firmware. 

Thanks for the input anyhow, at least I know for sure there is no chipless firmware available. Guess my only shot is now finding out if it's possible to find an earlier firmware version, then if it's possible to roll it back.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...