Jump to content
WIC Reset Program and Chipless Firmware
OmG

Epson WF-C5290 Epson Printer ROM - Program Update Mode

Recommended Posts

Hello Admin,

Is there a way to exit "Program Update Mode" I performed several Firmware Update - the old, the latest FW from Epson support website and the chipless firmware- but of no luck, I got the same status when I turn on the printer "Program Update Mode".

This is what I've done from this LCD screen every time I turned on the printer

a.PNG.08b649057a1f41a4f62e2688ace8ead2.PNG

USB port detected on WIC software

2.PNG.fe628c6b29be12b2d16014fed67ed705.PNG

 

but not on Firmware Update software

1.PNG.9151ed0951e9ce4ddfa25045b93c731b.PNG

 

but if I press STOP+Arrow Down+Arrow Left+Power button the Firmware Software able to detect the USB port

 

b.PNG.9a9f57778b6c32f0d0ca6fde4b074ed9.PNG

 

 

3.PNG.507fd8c9ce79ab92a02cb0246a189038.PNG

 

4.PNG.1d1f96e3ecc8fb3639ea749bc4174fd5.PNG

 

then I can continue with the Firmware update

after finishing the update, this screen appeared with all lights blinking, then back to the start

 

c.PNG.d904d1f28b289332a3a92aba0956e6d5.PNG

 

I also tried the recovery mode, that perform unplugging of power cable to corrupt the file written on the motherboard. same result

 

What should I do to recover my printer to work again.

 

Thank you in advance!!!

 

5.PNG

Share this post


Link to post
Share on other sites

same error even if I used different usb data cable half a meter size, I also try to run WIC Reset in Administrator mode, same with the Firmware Update software

 

Share this post


Link to post
Share on other sites

I also encountered the same problem as the author with my WF-C5290.

Epson Printer ROM - Program Update Mode appears on the screen.

No matter which method is used, the machine will display like this when it is turned on.

I wonder if the theme author has solved the problem???

Share this post


Link to post
Share on other sites

Not yet, I've tried all possible solution, still the same problem.

Share this post


Link to post
Share on other sites

Finally the usb detected on normal mode with the screen printer display - Epson device rom program update mode -

I installed Epson  Software Updater and the time it connect and try to update the software I checked if the Firmware update software could detect the printer - it does.\

How ever the prior problem still exist. I'd try to update firmware to solve this problem.    

449903865_831060465341240_8829828234140437945_n.thumb.jpg.75d41eb6e112e2c129720f7a23b3560e.jpg

 

with this report on wic software

215333805_fwupdatesuccess4.PNG.b9e0b508343a85a80ae8b6515ed4c8d1.PNG 

\\

i restored the recovery key for chipless firmware successfuly

\\

i noticed that this occur more frequently, sometimes the printer run smoothly 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...