Jump to content
WIC Reset Program and Chipless Firmware
Sign in to follow this  

Recovery Mode Solution

Recommended Posts

My Epson printer is stuck in Recovery Mode. How to solve?


600.jpg 2750.jpg


This message is displayed on the product’s LCD screen and you will be unable to perform any actions until this issue is resolved.


This error can occur if the firmware update procedure is interrupted, e.g. accidental powering off the product, cables being removed or the installation being cancelled.


Install in Your printer Epson original ink cartridges.


If Your WF2750 printer has stuck in Recovery Mode - run application (at the bottom of this page), follow all 7 steps and wait until firmware update is finished.

Restart printer - it have to be in ready to print mode.


If before Recovery mode your printer had Ink Out error or other kind of errors - You have to run application after You put printer in special Firmware Update mode.


You have to press and hold specific buttons combination on printer panel to enter in Firmware Update mode.

You will see text in WHITE color on printers display - Program Update mode


If text is in red color - that is wrong mode.

Try once more time.


Download Recovery Firmware here - http://www.ChiplessSolutions.com/download/recovery/Recovery_wf2750.zip

Share this post

Link to post
Share on other sites

I recently tried to make my XP-342 chipless. I tried to do it in normal mode, and it didn't work. So I tried contacting the live online help and was waiting for over 3 hours without success.


I then decided to bite the bullet and buy yet another firmware key to try and do the update in system mode. I got the error message "ROM NOT WRITABLE", and then the printer got stuck in "RECOVERY MODE".


After digging around on the forum I came across the message that printers made from 2015 on-wards can't be updated as the EEPROM is not writable. I literally bought this printer brand new today because I wanted a chipless printer...I chose the XP-342 specifically after checking the supported models list....i'm now out of pocket by 2 firmware keys and the cost of the printer which is now completely broken and unresponsive.


I've tried the attached program but that doesn't work either - it just says "FILE NOT FOUND" on the printer after it's been uploaded.


I've sent an email to the person listed as the seller of the 2 firmware keys I purchased - but considering how disgusting the live chat service was i'm not gonna hold my breath. So, basically I just threw away ВЈ85.76 today and still need to buy yet another printer :(


If anyone knows a way this printer can be fixed before I purchase yet another one, I think I'd have to marry you.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...