Jump to content
WIC Reset Program and Chipless Firmware

Recommended Posts

Not sure what I am doing wrong.  Go through procedure for downloading replacement firmware.  Gets to end 99% and get message "Firmware did not complete" Choice to "retry" or "continue".  I try retry first = same result.  Then run firmware update again and get same result and then I click on "continue" =  Same result.  File version being loaded is 30.74. CL99Z9.  Fimware File =FWF469TL.

Printer attached to desktop computer via USB cord. 

Share this post

Link to post
Share on other sites

Hello John,

I did follow the process you sent to me.  Same Result.  However, before we go to much further, I did check the current firmware version.  Both the report button and a menu selection under "printer data" (current firmware version) both show the current version is Cl 30J5 30/05/2019.  I attached a copy of the report below.

Does this mean I can go ahead with step 5 and purchase the activation key?

Mike K.

Report For WF-3720.txt

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...