Jump to content
Printer Reset Forum
fatherandepson

WF 4720 wrong id readed from the printer - new firmware?

Recommended Posts

Fixed now! I got impatient and got it working using the bricking/interruption method explained here:

.........

Another important note that may help people frustrated with the WF4720 Firmware Update mode. None of the pressing positions worked for me and I searched all over the web. Almost gave up...then it worked.

This was my exact setup:

1. Turn printer off. Still plugged into power.

2. Connect to your computer with cable >>> USB Type A male cable with the printer Type B male on the other end. 

3. The button presses... only this worked for me:

>>>> First put your thumb print (not just tip, more flat and horizontal) in the top right part of the black glass...not the display box inside...outside that on the glass's top right area.

Start pressing this first.

>>>> Quickly press and hold the power button...keep on holding. If you're doing it right there won't be a blue light for 20 seconds and screen will be dark.

>>> HOLLLLLDDDD

>>> As soon as the blue light goes on, release! And boom!

I saw this 20s technique for other models on YouTube, but everything for the WF4720 said 3 seconds and all the variations on this just turned on the printer.

Glad I played around with it. This is a store-bought Canadian model.

Good luck all! Thanks for your service chipless. Damn ink robbery with those companies.

Share this post


Link to post
Share on other sites

Fatherandepson, what was the file name for yours? I'm getting the same error and have tried a few times to get it working with no luck. I have a wf-4730 so I think the same file as your 4720. 

Share this post


Link to post
Share on other sites

Thanks for your response! As far as I can tell I'm following all the steps, but when I'm in the installer , the firmware version says 30.69.CM23I5

But the version that shows up on the printer when it's finished is 30.74.CM27J9

I can't figure out what's going wrong. I've tried redoing it multiple times...

Share this post


Link to post
Share on other sites

Awesome. Yeah I hit the same problem and finally I said screw it, time for the nuclear option. Glad it worked.

For me the hardest part was getting into Firmware Update mode. I must've gotten the one special 4720 that has a 20 second secret button hold time haha. Damn Epson trying to take our money and our sanity.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...